Прехвърляне към съдържание


Снимка

Проблем със споделяне на интернет посредством суич и прокси сървър

суич мрежа компютър лан връзка проблем

  • Моля, влезте, за да отговорите
6 отговора по тази тема

#1 KurtCobain...

KurtCobain...

    Потребител

  • Потребители
  • ПипПипПипПипПипПип
  • 7 мнения
  • Пол:Мъж
  • Живущ в:Благоевград
  • Интереси:Футбол, Компютърни технологии, Музика

Публикувано: 01 December 2012 - 22:16

Добър вечер! :) Много ще съм Ви благодарен, ако ми обърнете внимание (за което мисля, че сте напълно готови, защото не веднъж сте ми помагали и може би нямаше да съм на това ниво (колкото и скромно да е то) без Вас). Та казуса е следният: У дома има няколко компютъра и преди доста време се поинтересувах дали мога да ги свържа някакси в мрежа и да споделям интернет и на останалите компютри, а не само на единия. Поинтересувах се и четох статия от вашият форум по този въпрос и първият начин, който използвах бе чрез блутуут и програмата CCPrxy. Таа всичко вървеше наред, свързах ги, имах си интернет на всички компютри (тогава те бяха 2 в една стая), но по стечение на обстоятелствата трябваше да ги "разделя" (компютрите) и да не са в една стая, а и изгубих единия блутуут, който и без това нямаше да ми върши повече работа. След известно време се позамислих, че щом с блутуут става значи със суич няма защо да не стане! И да, стана! (не го и подлагах под съмнение - чиста формалност). Споделях интернет години... До скоро... Преди няколко месеца смених доставчика и всичко си беше както преди, но от 1-2 месеца. Връзката се загуби тотално, а не стига, че 2-рия и 3-тия компютър не можеха да се свържат към интернет, ами и самата връзка в ЛАН мрежата се загуби. Сменях кабели, суичове, преинсталирах "главният" компютър... (е не съм давал пари за тях естествено. защото не е изгодно да влагаш средства в такъв вид мрежа, но ми попадаха по стечение на нещата нужните материали та пробвах всичко) пробвах всичко каквото може, но уви! И сега най-интересният факт за мен - когато кабела за интернета не е включен 2-та (3-та) компютъра са си в мрежа и се откриват (споделям си файлове), а докато е в суича и се предава към "главния" или е директно свързан към него и свържа към 2-рата ЛАН карта кабел към суича, към който са свързани останалите, нищо не става - нито ЛАН мрежа, нито интернет! Ще съм Ви благодарен, ако ми разнищите тази мистерия!! :)) Майната му на интернета, но все пак искам да знам... ЗАЩО!?!?

#2 panevdd

panevdd

    Потребител

  • Глобални модератори
  • ПипПипПипПипПипПип
  • 3006 мнения
  • Пол:Мъж
  • Живущ в:Сунгурларе
  • Интереси:Икономика, Информационни технологии, Пчеларство

Публикувано: 01 December 2012 - 22:31

Нарисувай или начертай една примерна схема с компютрите и другите устройства, за да видим как точно е организирана мрежата у вас.
Публикувано изображение Публикувано изображение
Не съществува такова нещо като абсолютна обективност. Затова ползвам Google, Wikipedia, търсачката на форума, чета някои съвети и правилата на форума.

#3 KurtCobain...

KurtCobain...

    Потребител

  • Потребители
  • ПипПипПипПипПипПип
  • 7 мнения
  • Пол:Мъж
  • Живущ в:Благоевград
  • Интереси:Футбол, Компютърни технологии, Музика

Публикувано: 02 December 2012 - 12:42

Публикувано изображение
Това е схемата, която ползвах много време и нямаше проблем докато изведнъж всичко изчезна(докато се появи сегашният ми казус), а по-долу е схемата, която пробвах наскоро, но даде същия (никакъв) резултат.
Публикувано изображение
Относно настройките на ЛАН картите, всичко е наред. Интересен факт, който забравих да спомена снощи, защото бързах бе това, че примерно сега, ако опитам пак да ги свържа ще мога да си споделям файловете м-у тях (ще са си в мрежа), но това е за много кратко време (минути).

#4 panevdd

panevdd

    Потребител

  • Глобални модератори
  • ПипПипПипПипПипПип
  • 3006 мнения
  • Пол:Мъж
  • Живущ в:Сунгурларе
  • Интереси:Икономика, Информационни технологии, Пчеларство

Публикувано: 02 December 2012 - 17:36

Втората схема би трябвало да е правилна.
По какъв начин получаваш достъп до Интернет - статичен адрес, DHCP, PPPoE, нещо друго?
Какви настройки си направил в CCProxy и в мрежата на PC1?
Какви настройки на мрежата си направил на останалите компютри?
Публикувано изображение Публикувано изображение
Не съществува такова нещо като абсолютна обективност. Затова ползвам Google, Wikipedia, търсачката на форума, чета някои съвети и правилата на форума.

#5 KurtCobain...

KurtCobain...

    Потребител

  • Потребители
  • ПипПипПипПипПипПип
  • 7 мнения
  • Пол:Мъж
  • Живущ в:Благоевград
  • Интереси:Футбол, Компютърни технологии, Музика

Публикувано: 03 December 2012 - 19:42

Чрез PPPoE (чрез потребителско име и парола). А настройките на PC1 са: IP 192.168.0.1 SM 255.255.255.0 , в една работна група с останалите e. На останалите са същите само дето са с различна последна цифра (IP-тата)(2,3 и т.н). На CCProxy настройките (портовете) не съм ги променял. С първата схема всичко си беше наред до преди известно време, пак си бях чрез PPPoE, пак със суич и т.н. Втората схема я пробвах наскоро, но и с нея нищо. Просто се чудя защо не само, че нямам достъп до интернет с останалите машини ами и че нямам достъп до самата ЛАН мрежа. Четох дали може да ми се ограничи споделянето на нета, но където и да съм чел пише, че чрез прокси няма как. Пък и да има как няма как да ми ограничават ЛАН мрежата от някъде другаде! (нали?) Знам как се споделя така интернет, просто не знам какви са причините да не се получава. Какво ли не пробвах... резултат никакъв!

#6 panevdd

panevdd

    Потребител

  • Глобални модератори
  • ПипПипПипПипПипПип
  • 3006 мнения
  • Пол:Мъж
  • Живущ в:Сунгурларе
  • Интереси:Икономика, Информационни технологии, Пчеларство

Публикувано: 03 December 2012 - 21:41

Изключи CCProxy и кабела на доставчика. Провери още веднъж настройките за адресите на компютрите; за всеки случай можеш да промениш адресите - например 192.168.90.100 (за РС1) и 192.168.90.101 (съответно 192.168.90.102) за РС2 и РС3. Маската е 255.255.255.0, без настройки за шлюз и proxy. Казваш, че компютрите са в една работна група... имат ли пароли на потребителските профили? Направи по един потребител shareuser на всички компютри с еднаква парола, може и да не е администратор. При това положение, ако имаш споделени папки, би трябвало да се "виждат" в мрежата или поне да имаш достъп до тях, когато в Windows Explorer въведеш пътя с IP адеса (например \\192.168.90.101\споделена_папка).
Ако до тук всичко работи, остава да провериш настройките на CCProxy и съответно - да въведеш настройки за шлюз и proxy при РС2 и РС3.
Публикувано изображение Публикувано изображение
Не съществува такова нещо като абсолютна обективност. Затова ползвам Google, Wikipedia, търсачката на форума, чета някои съвети и правилата на форума.

#7 KurtCobain...

KurtCobain...

    Потребител

  • Потребители
  • ПипПипПипПипПипПип
  • 7 мнения
  • Пол:Мъж
  • Живущ в:Благоевград
  • Интереси:Футбол, Компютърни технологии, Музика

Публикувано: 04 December 2012 - 14:45

Снощи отново попрегледах настройките на PPPoE връзката и на CCProxy. В настройките на PPPoE беше зададено тикче на "Позволи на други мрежови потрбители да се свързват чрез интернет връзката на този компютър" и аз го премахнах, защото съвсем експериментално пробвах да направя PPPoE връзка на един от другите компютри да видя настройките общо взето (защото нямах достъп до "главния" компютър (чисто физически, не чрез компютъра(това вече уточнихме, че не може :D )) в същото време) И видях, че фабричните настройки са му без тикче и щом му зададох тикчето и се появи предупредителен прозорец, в който пишеше, че така щяла да се загуби връзката чрез IP 192.168.0.... И от там веднага отидох до "главния копмпютър" и видях, че има тикче и там... премахнах го. Днес пробвах да свържа компютрите и се получи, но интернет нямаше. Насочих се към прoграмата (CCProxy). Поразрових се из настройките и пробвах да видя какво ще стане, ако махна тичкчето от "Enable Multiple IP's Outgoing" (то доколкото си спомням фабрично и то не е зададено, но в процес на всичките тези барникания на настройките съм ги задавал, а съм забравял да ги връщам обратно, та е станала една какфония...). Та сега да не кажа голяма дума мрежата работи както трябва и мога да споделям интернет (поне засега :D ).





Други теми с тагове суич, мрежа, компютър, лан, връзка, проблем

0 потребители четат тази тема

0 регистрирани потребители, 0 гости и 0 анонимни потребители